IPv6 এর বেসিক ধারণা

IPv6 হলো একটি প্রটোকল। IPv6 এর এড্রেস হলো ১২৮ বিটের। ইন্টারনেটে নতুন পরিচয় হিসেবে চালু হলো ইন্টারনেট প্রটোকল ভার্সন ৬ (IPv6) ইন্টারনেট সোসাইটির বরাতে এক খবরে বিবিসি জানিয়েছে, ট্রিলিয়নেরও অধিক ইন্টারনেট ব্যবহারকারীর নিজস্ব আইপি ঠিকানা হিসেবে পরিচিতি দিতেই আইপিভি ৬ চালু হয়েছে। কেন IPv6 প্রয়োজন? আমরা সবাই জানি IPv4 হলো ৩২ বিটের। সুতরাং এর এড্রেসের সংখ্যা হলো ২^৩২ = ৪২৯৪৯৬৭২৯৬ টি। কিন্তু ইন্টারনেট ব্যবহারের সংখ্যা যেভাবে দিন দিন বৃদ্ধি পাচ্ছে, এই এড্রেসগুলো দ্রুতই শেষ হয়ে যাবে। তাই এই সীমাবদ্ধতা দূর করার জন্য IPv6 এর সংস্করন। IPv6 এর প্রকারভেদ ১) ইউনিকাস্ট (Unicast) ইউনিকাস্ট হলো সিঙ্গেল ইন্টারফেস আইডেন্টিফায়ার। অথার্ৎ ওয়ান টু ওয়ান কমিউনিকেশন। যেমন- আপনি একটি ফাই ল সার্ভার এর কথা ভাবতে পারেন। আপনার ফাইল ষার্ভার হলো সেন্ডার আর আপনার কম্পিউটার হলো রিসিভার।
2) মাল্টিকাস্ট (Multicast)
3) IPv6 এ মাল্টিকাস্ট এড্রেস হলো FF00::/8. IPv6 এর এই মাল্টিকাস্টিং এড্রেসকে IPv4 এর Broadcast এর সাথে তুলনা করা যায়। অনেকগুলি হোস্টে নিকট কোনো মেসেজ পাঠাতে IPv6 এই মাল্টিকাস্ট ব্যবহার করে। লক্ষ্যণীয় যে IPv6 এ Broadcast নেই, ফলে মাল্টিকাস্ট অনেক গুরুত্বপূর্ন।
4) মাল্টিকাস্ট হলো গ্রুপ অফ নোডের আইডেন্টিফায়ার। অথার্ৎ ওয়ান টু মেনি। এই ধরনের কমিউনিকেশনে সেন্ডার গ্রুপ অফ হোস্টের সাথে কমিউনিকেট করতে পারে।
৩) এনিকাস্ট (Anycast)
এনিকাস্ট হলো সেট অফ ইন্টারফেসের আইডেন্টিফায়ার। যদি একই ধরনের সার্ভার থাকে আহলে একটি আইপি একাধিক সার্ভারের সাথে কমিউনিকেট করতে পারে। ইহা কমিউকেট করে থাকে ডিসটেন্স এর উপরে।

IPv6 এড্রেস রিপ্রেজেন্টশন:
অনেকেই IPv6 এর এড্রেস দেখে মনে করে এত বড় আমরা মনে রাখা তো কঠিন কাজ। কিন্তু এই কঠিন কাজই আমরা খুব সহজেই মনে রাখতে পারি। মনে করি আমাদের একটি IPv6 এোড্রস হলো
2001:0BA7:0002:008D:0000:0000:42A6:52F5
এই এড্রেসটি আমরা খুব সহজেই 0 গুলোকে বাদ দিয়ে লিখতে পারি
2001:BA7 :2:8D:0:0:42A6:51F5
ফাইনালে আমরা এই এড্রেসটাকে এভাবে লিখতে পারি
2001:BA7:2:8D::42A6:51F5

IPv6 এর রেঞ্জ
IPv6 এর রেঞ্জ অনেক বেশি
আপনি গুনে শেষ করতে পারবেন না
এর রেঞ্জ হচ্ছে 3.4*10³⁸

চলুন এবার একটি গুরুত্বর্পুন বিষয় নিয়ে আলোচনা করি। আমাদের IPv4 এর মধ্যে দিয়ে মধ্যে দিয়ে কিভাবে IPv6 এর টানেলিং করা যায়, সেই বিষয়টি দেখি….
আপনাদের বুঝার সুবিধার্থে দুইটা Cisco রাউটার নিচ্ছি
R1 ও R2

R1 router Interface configuration command line:
Router>en
Router#configure ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.20.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface fastEthernet 0/1
R1(config-if)#ip address 192.168.30.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#ipv6 address FEC0::1:1/120
R1(config-if)#no shutdown
R1(config-if)#

R2 Router interface configuration command line
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#exit
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#wr
Building configuration…

Routing
EIGRP configure in R1 router
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#rou
R1(config)#router ei
R1(config)#router eigrp 1
R1(config-router)#net
R1(config-router)#network 192.168.30.0
R1(config-router)#net
R1(config-router)#network 192.168.20.0
R1(config-router)#
R1#

EIGRP configure in R2 router
R2#en
R2#conf
R2#configure ter
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router eigrp 1
R2(config-router)#network 192.168.20.0
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.20.1 (FastEthernet0/0) is up: new adjacency
net
R2(config-router)#network 192.168.40.0
R2(config-router)#exit
R2(config)#exit
R2#
%SYS-5-CONFIG_I: Configured from console by console

R2#wr
Building configuration…
[OK]
R2#

R1 to R2 router tunnel configuration command

R1 router command line
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface tunnel
% Incomplete command.
R1(config)#interface tunnel 1
R1(config-if)#
%LINK-5-CHANGED: Interface Tunnel1, changed state to up
R1(config-if)#ipv6 enable
R1(config-if)#tunnel mode ipv6ip
R1(config-if)#tunnel source fastEthernet 0/0
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up
R1(config-if)#tunnel destination 192.168.20.2
R1(config-if)#ipv6 address FEC0::14:2/120
R1(config-if)#exit
R1(config)#exit
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#wr
Building configuration…
[OK]
R1#

R2 router command line
R2>en
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface tunnel 1
R2(config-if)#
%LINK-5-CHANGED: Interface Tunnel1, changed state to up
R2(config-if)#ipv6 enable
R2(config-if)#tunnel mode ipv6ip
R2(config-if)#tunnel source fastEthernet 0/0
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up
R2(config-if)#tunnel destination 192.168.20.1
R2(config-if)#ipv6 address FEC0::14:1/120
R2(config-if)#no shutdown
R2(config-if)#

Routing enable in R1 for IPv6
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ipv6 unicast-routing
R1(config)#interface fastEthernet 0/1
R1(config-if)#ipv6 eigrp 5
R1(config-if)#exit
R1(config)#interface tunnel 1
R1(config-if)#ipv6 eigrp 5
R1(config-if)#ipv6 router eigrp 5
R1(config-rtr)#no shutdown

Routing enable in R2 for IPv6
R2#configure terminal
R2(config)#ipv6 unicast-routing
R2(config)#interface fastEthernet 0/1
R2(config-if)#ipv6 eigrp 5
R2(config-if)#exit
R2(config)#interface tunnel 1
R2(config-if)#ipv6 eigrp 5
R2(config-if)#ipv6 router eigrp 5
R2(config-rtr)#no shutdown
R2(config-rtr)#

IPv4 এর মধ্যে দিয়ে মধ্যে দিয়ে কিভাবে IPv6 এর টানেলিং শেষ।

WAN (Wide Area Network)
আমার তো আগেই জেনেছি যে, দূরবর্তী ল্যানসমূকে নিয়ে গড়ে উঠা নেটওয়ার্ককে ওয়াইড এরিয়া নেটওয়ার্ক বলে। এ ধরনের নেটওয়ার্ক এর ডাটা ট্রান্সফার স্পীড ৫৬ কেবিপিএস থেকে ১.৫৪৪এমবিপিএস হয়ে থাকে। ওয়্যানের গতি ধীরে ধীরে পরিবর্তন হচ্ছে। এ ধরনের নেটওয়ার্কে ব্যবহিত ডিভাইসগুলো হলো রাউটার, মডেম, ওয়্যান সুইজ ইত্যাদি।

WAN কেন প্রয়োজন?
একাধিক দূরবর্তী নেটওর্য়াক গুলোর মধ্যে রিসোর্স শেয়ার করার জন্য WAN প্রয়োজন. ধরেন আপনার অফিসের কয়েকটি সাব অফিস বিভিন্ন স্থানে রয়েছে এখন যদি আপনি সাব অফিস গুলোর রিসোর্স ব্যবহার করতে চান তাহলে আপনার ওয়্যান কানেক্টিভিটি প্রয়োজন। কি কি টাইপের WAN কানেকশন হয়? ডেডিকেটেড লিজড লাইন কানেশন সার্কিট সুইজড কানেকশন প্যাকেট সুইচড কানেকশন ডেডিকেটেড লিজড লাইন কানেশন ডেডিকেটেড লিজড লাইন কানেশন হলো এক জন কাস্টমার কর্তৃক ব্যবহিত হয়। কাস্টমার সার্ভিস প্রভাইডার এর নিকট থেকে নিদির্র্ষ্ট সময় এর জন্য ভাড়া নেয়। ইহা হলো সাধারণত পয়েন্ট টু পয়েন্ট কানেশন। সার্কিট সুইজড কানেকশন সার্কিট সুইজড কানেকশন হলো টেলিফোন কানেকশন এই কানেকশন একবার স্থাপন হলে সংযোগ বিচ্ছিন্ন না হওয়া পর্যন্ত ব্যস্ত থাকে। এই কানেকশনের সুবিধা হলো কোন ইন্টারপারেন্স নেই, ডেডিকেটেড অবস্থায় কল থাকে। ফলে সকল ব্যান্ডওয়াইড ব্যবহার হয় এবং শেয়ারেই এর জামেলা নাই। তবে অসুবিধা হলো যদি জরুরী কোন স্থাপন করার প্রয়োজন হয় তাহলে তা স্থাপন করা সম্ভব নয় যদি কানেকশন ব্যস্ত থাকে।

প্যাকেট সুইচড কানেকশন।
প্যাকেট সুইচড কানেকশন এ ম্যাসেজটা ছোট ছোট প্যাকেটে পরিণত হয় এবং প্যাকেট গুলো একাধিক পথ দিয়ে গমন করে তাই কোন পথে যদি সমস্যা থাকে তাহলে অন্য পথ দিয়ে গমন করে। প্রত্যেকটি প্যাকেট এর সাথে হেডার সংযুক্ত থাকে ফলে রিসিভার হেডারগুলো দেখে দেখে ম্যাসেজ গ্রহন করে। এর প্রধান সুবিধা হলো যেহেতু একাধিক পথ থাকে ফলে রিসিভার দেরিতে হলেও ম্যাসেজ পায়। এর অসুবিধা হলো রিয়েল টাইম যোগাযোগ এর সময় কোন কাজে আসে না।

এতক্ষন আমরা দেখলাম WAN কি, কেন আমরা WAN কনিফগার করি এবং এই WAN কি কি টাইপের হয়।
এখন সম্ভবতই প্রশ্ন আসে WAN কিভাবে কনফিগার করা যায়।

তাই আজকে আমরা দেখব Point to Point Protocol(PPP) এর মাধ্যমে কিভাবে WAN কনফিগার করা যায়।
চলুন তাহলে শুরু করা যাক

আজকে আমরা দেখবো WAN এ PPP কিভাবে কনফিগার করা যায় সাথে CHAP authentication

Interface configuration of R1 router configuration command line
Router>en
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host
Router(config)#hostname R1
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Interface configuration of R2 router:
Router>en
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R2(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.11.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#no shutdown

R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routing configuration command for R1
R1(config)#router rip
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.10.0
R1(config-router)#

Routing configuration command for R2
R2(config)#router rip
R2(config-router)#net
R2(config-router)#network 192.168.11.0
R2(config-router)#net
R2(config-router)#network 192.168.12.0
R2(config-router)#

Configure PPP in R1 router with CHAP authentication
R1(config)#username R2 password 123456778
R1(config)#interface serial 0/0/0
R1(config-if)#encapsulation ppp
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
R1(config-if)#ppp authentication chap
R1(config-if)#

Configure PPP in R2 router with CHAP authentication
R2(config)#username R2 password 123456788
R2(config)#interface serial 0/0/0
R2(config-if)#encapsulation ppp
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#ppp authentication chap
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

বাহ! আউটপুট ও পেয়ে গেলাম সাথে কাজও শেষ
Hot Standby Router Protocol (HSRP)
HSRP হলো সিসকো প্রোপ্রাইটারী প্রটোকল। এই প্রটোকল যে কাজটি করে তা হলো যদি দুইটি রাউটার থাকে তাহলে একটি রাউটারকে একটিভ আরেকটি রাউটারকে স্ট্যান্ডবাই রাখে। ফলে একটি রাউটার যদি কাজ না করে তাহলে অন্য রাউটার দিয়ে কাজ সর্ম্পূণ হয়।
চলেন তাহলে দেখি HSRP কিভাবে কাজ করে,
মনেকরি আমাদের নেটওয়ার্কটি দেখতে নীচের ছবিটির মত। যেখানে দুইটি রাউটার আছে। অথার্ৎ রাউটার (R1) একটিভ থাকবে এবং আরেকটি রাউটার (R2) স্ট্যান্ডবাই আছে।
Hot Standby Router Protocol (HSRP)

এখন যদি একটি রাউটার (R1) অকেজো হয়ে যায় স্ট্যান্ডবাই রাউটার একটিভ মোডে রুপান্তর হয়ে যাবে।

Virtual Router Redundancy Protocol (VRRP)
VRRP হলো ওপেন স্ট্যার্ন্ডাড প্রটোকল। এটার ফাংশনালিটি HSRP এর মত। অর্থাৎ এই প্রটোকলও যে কাজটি করে তা হলো যদি দুইটি রাউটার থাকে তাহলে একটি রাউটারকে একটিভ আরেকটি রাউটারকে স্ট্যান্ডবাই রাখে। ফলে একটি রাউটার যদি কাজ না করে তাহলে অন্য রাউটার দিয়ে কাজ সর্ম্পূণ হয়।
Gateway Load Balancing Protocol (GLBP)
GLBP হলো ওপেন স্ট্যার্ন্ডাড প্রটোকল। এই প্রটোকলও যে কাজটি করে তা হলো যদি দুইটি রাউটার থাকে তাহলে দুইটি রাউটারকে একটিভ রাখে এবং লোড ব্যালেন্স করে থাকে।
চলেন তাহলে দেখি GLBP কিভাবে কাজ করে
GLBP যদি দুইটি রাউটার থাকে তাহলে দুইটি রাউটারকে একটিভ রাখে এবং লোড ব্যালেন্স করে থাকে।

এখন যদি একটি রাউটার (R1) অকেজো হয়ে যায় অন্য রাউটার দিয়ে সকল প্যাকেট ট্রান্সফার হয়ে থাকে।
আমরা আজকে দেখব কিভাবে HSRP কনফিগার করতে হয়।
প্রথমে আমরা নেটওয়ার্কটি ডিজাইন করি

কনফিগারেশন
HSRP Router1 interface configuration command line :
Router>en
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# hostname HSRPRouter1
HSRPRouter1(config)# interface gigabitEthernet 0/0
HSRPRouter1(config-if)# ip address 192.168.1.3 255.255.255.0
HSRPRouter1(config-if)# no shutdown
HSRPRouter1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
HSRPRouter1(config-if)#
HSRPRouter1(config-if)# exit
HSRPRouter1(config)# interface gigabitEthernet 0/1
HSRPRouter1(config-if)# ip address 1.1.1.1 255.255.255.0
HSRPRouter1(config-if)# no shutdown
HSRPRouter1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
exit
HSRP Router2 interface configuration command line
Router>
Router>en
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitEthernet 0/0
Router(config-if)# ip address 192.168.1.2 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)# exit
Router(config)# interface gigabitEthernet 0/1
Router(config-if)# ip address 1.1.1.2 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Router(config-if)# exit
Router(config)# hostname HSRPRouter2
ISP router interface configuration command line
Router>en
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

Router(config)# hostname ISP
ISP(config)# nterface gigabitEthernet 0/1
ISP(config-if)# ip address 1.1.1.3 255.255.255.0
ISP(config-if)# no shutdown
ISP(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Routing configuration for ISP router
ISP(config)# ip route 0.0.0.0 0.0.0.0 gigabitEthernet 0/1
HSRP configuration command line for HSRP Router1
HSRPRouter1(config)# interface gigabitEthernet 0/0
HSRPRouter1(config-if)# standby 1 ip 192.168.1.254
HSRP configuration command line for HSRPRouter2
Router(config)# hostname HSRPRouter2
HSRPRouter2(config)# interface gigabitEthernet 0/0

HSRPRouter2(config-if)# standby 1 ip 192.168.1.254

যেতেতু আমি নেটওয়ার্ক সেক্টর নিয়ে কাজ করি না
তাই এগুলো তেমন ভালোভাবে বুঝি না
যদি ভুল্ট্রুটি করে থাকি ক্ষমা করবেন এবং আমার ভুল গুলো আমাকে দেখিয়ে দিবেন।

Level 2

আমি তানভীর খন্দকার। বিশ্বের সর্ববৃহৎ বিজ্ঞান ও প্রযুক্তির সৌশল নেটওয়ার্ক - টেকটিউনস এ আমি 8 বছর 8 মাস যাবৎ যুক্ত আছি। টেকটিউনস আমি এ পর্যন্ত 10 টি টিউন ও 18 টি টিউমেন্ট করেছি। টেকটিউনসে আমার 7 ফলোয়ার আছে এবং আমি টেকটিউনসে 9 টিউনারকে ফলো করি।

Ethical Hacker || Bug Hunter || Red Team Member at @SynackRedTeam|| Admin at CTF_Community_Bangladesh || Admin at Bug_Bounty_Community_Bangladesh


টিউনস


আরও টিউনস


টিউনারের আরও টিউনস


টিউমেন্টস